Version 2.2.51.0 or above: Could not create SSL/TLS secure channel (Konica Minolta Integrated)

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Version 2.2.51.0 or above: Could not create SSL/TLS secure channel (Konica Minolta Integrated)

Prior to version 2.2.51, the OpenAPI SDK used a default SSL protocol that would often result in an error during the initialisation of a device (Could not create SSL/TLS secure channel). To fix this, either a registry change was required on the machine where Resource Manager is running (see Version 2.2.50.1 and below: Could not create SSL/TLS secure channel), or a special firmware was required for the device.

PD version 2.2.51 (or above) should not suffer from the problem described above because it supports TLS 1.2. However, it has been reported that a similar problem occurs, and the fix described in Version 2.2.50.1 and below: Could not create SSL/TLS secure channel does not resolve the problem.

Symptoms

After clicking Gather Info, the following text appears in the output box:

This prevents the device from being Initialised.

Cause

Because PD supports TLS 1.2 and it is enabled on the device, the OpenAPI AppReq messages will attempt to use TLS 1.2. However, on the device in question (C3350, Controller ROM Version: A3GN30G0803-W99, Engine ROM Version: A3GN0Y00050G001900) the TLS 1.2 implementation was not working.

Resolution

Log in to the web interface of the device in Administrator mode. Disable TLS 1.2:

Now log out of the device and attempt the Gather Info again.  The initialisation should succeed.

Document revision date: 2019/01/24
Software version: 2.2.51.1

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